E6 Addressing Scheme and Network Architecture
About this article
Abstract
The paper describes new E6 addressing scheme for the creation of world-wide networks totally constructed on the base of Ethernet technology. Hierarchic E6 addresses with the length of 6 octets are used instead of both Ethernet MAC-addresses and IP-addresses that allows the routing within world-wide networks and cuts overhead of TCP, IP headers; the address space is extended in 16K times regarding IP addresses. Standard Ethernet LLC2 facilities are employed for guaranteed delivery of information. E6 Network Architecture simplifies packets processing algorithms that improves the network performance and QoS.References
[1] J. Postel, Transmission control protocol, RFC 793, 1981.
[2] J. Postel, User Datagram Protocol, RFC 768, 1980.
[3] J. Postel, Internet protocol, RFC 791, 1981.
[4] C. Hornig, A Standard for the Transmission of IP Datagrams over Ethernet Networks, RFC 894, 1984.
[5] J. Postel, Internet Control Message Protocol, RFC 792, September 1981.
View more references (15)
[6] Y. Rekhter, T. Li, An Architecture for IP Address Allocation with CIDR, RFC 1518, September 1993.
[7] C. Hedric, Routing Information Protocol, RFC 1058, 1988.
[8] J. Moy, OSPF specification, RFC 1131, October 1989.
[9] K. Egevang, P. Francis, The IP Network Address Translator (NAT), RFC 1631, May 1994.
[10] P. Mockapetris, Domain Names - Concepts and Facilities, RFC 1034, USC/Information Sciences Institute, November 1987.
[11] R. Droms, Dynamic Host Configuration Protocol, RFC 1531, Bucknell University, October 1993.
[12] Assigned Numbers: RFC 1700 is Replaced by an On-line Database / J. Reynolds, Ed., RFC 3232, January 2002.
[13] S. Deering, R. Hinden, Internet Protocol, Version 6 (IPv6) Specification, RFC 1883, January 1996.
[14] Carrier Sense Multiple Access with Collision Detection (CSMA/CD) Access method and Physical Layer Specifications, LAN/MAN Standards Committee of the IEEE Computer Society, IEEE Std 802.3-2005, Approved 9 June 2005, IEEE-SA Standards Board IP, 417 p.
[15] Logical Link Control, LAN/MAN Standards Committee of the IEEE Computer Society, IEEE Std 802.2, 1998 Edition (R2003), 239 p.
[16] P.P. Vorobiyenko, D.A. Zaitsev, O.L. Nechiporuk, “World-wide Network Ethernet?”, Zviazok (Communications), No. 5 (2007), pp. 14-19. In Russ.
[17] K.D. Guliaiev, D.A. Zaitsev, D.A. Litvin, E.V. Radchenko, “Simulating E6 Protocol Networks using CPN Tools”, Proc. of Int. Conf. on IT Promotion in Asia, Tashkent (Uzbekistan), 2008, pp. 203-208.
[18] Virtual Bridged Local Area Networks, Amendment 6: Provider Backbone Bridges, IEEE Draft P802.1ah/D4.2, Work in Progress, March 26, 2008.
[19] K.D. Guliaiev, D.A. Zaitsev, “Experimental Implementation of Networking Protocols Stack E6 into OS Linux Kernel”, Artificial Intelligence, No. 2 (2009), pp. 105-116. In Russ.
[20] Report on scientific-research work "New World-wide Networks Addressing Systems Development", state register number 0108U008900 / D.A. Zaitsev, T.R. Shmeleva, K.D. Guliaiev // Odessa: ONAT (2009), 124 p. In Ukr.